Technician Talk

02 Dodge Ram 2500 L6 24V

This question is answered

So.... I was turning onto the highway yesterday and when I accelerated, I heard a loud pop and then a lot of air being sucked in somewhere. I drove 11 miles to the nearest town, with no decrease in power or performance. When I stopped, I could not reproduce the sound again idling. No leaks, no high temps, nothing that would show anything is wrong. Is there anything wrong? What should I check for? I need help guys. Please 

Verified Answer
  • Have you checked all of the intercooler boots? I blew one off of the drivers side bottom of the cooler and it sounds like what you're experiencing. Hopefully that's all it is.

All Replies
  • Thank you for subscribing to ChiltonDIY!

    If the popping noise is coming from the engine, check the fuel rail pressure. Low fuel pressure can cause a popping sound in the intake/exhaust.

    Has the fuel filter been changed in the last 10,000 miles? Check all vacuum lines. Do you have the timing advanced to much? Check the intake and exhaust system for leaks.

    A valve problem could cause this but the vehicle would be running and idling poorly.

    If the popping noise is coming from the suspension check the steering and suspension system for worn parts. Track bars are known to make popping noises.

  • Ok, so to be clear as I was excited when I posted this, it popped once and it sounded like something deflating and a winding down sound. Now when I accelerate, its a rush of air and a bit of whining noise. I've checked the turbocharger itself, and there is just a slight bit of movement from back to front, but nothing like what's been described as being an issue. The rotor itself spins the way I've read its supposed to. The hoses are all in one piece, meaning no holes or splits. I'm really at a loss. I need some guidance as to what to check or do next. Honestly, I really can't afford to replace the Holset that's in there. If anyone can help, please post here, or call or text 808-238-8182. I want to do this myself if I can. Mahalo in advance.

  • Ok, so to be clear as I was excited when I posted this, it popped once and it sounded like something deflating and a winding down sound. Now when I accelerate, its a rush of air and a bit of whining noise. I've checked the turbocharger itself, and there is just a slight bit of movement from back to front, but nothing like what's been described as being an issue. The rotor itself spins the way I've read its supposed to. The hoses are all in one piece, meaning no holes or splits. I'm really at a loss. I need some guidance as to what to check or do next. Honestly, I really can't afford to replace the Holset that's in there. If anyone can help, please post here, or call or text 808-238-8182. I want to do this myself if I can. Mahalo in advance.

  • Have you checked all of the intercooler boots? I blew one off of the drivers side bottom of the cooler and it sounds like what you're experiencing. Hopefully that's all it is.

  • Yes, I would recheck the intake and intercooler system for something leaking. The pop may have caused something to leak which in turn is causing the sucking sound.